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SOLR has crashed, and an alert indicates that it is not available

Original Question or Issue:

We received the message below every day: 

"SOLR not available"

We have to restart the SOLR service manually. 


Environment:

  • Product - FileCloud Server
  • Version - Any
  • Platform - Any

Steps to Reproduce:

 


Error or Log Message:

330377cb1e1a7cec1411efa347d4f89246b473f62414bc92ca55644497897599f86650491b89675b?t=67d1689871361aaca5a77eb3f0629eaa

#  fatal error: OutOfMemory encountered: Java heap space
#
# JRE version: OpenJDK Runtime Environment (11.0.2+9) (build 11.0.2+9)
# Java VM: OpenJDK 64-Bit Server VM (11.0.2+9, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Core dump will be written. Default location: C:\xampp\solr\server\hs_err_pid9048.mdmp


Defect or Enhancement Number:

 


Cause:

SOLR crashes with an out-of-memory error. In some installations with large numbers of files (especially text-based documents), the heap memory is insufficient.


Resolution or Workaround:

To increase the heap size for SOLR, please follow these steps:

  • If the Solr server does not stop when stopped from services, open the control panel and kill the Java process. Make sure no process is listening at port 8983.
  • Solr may require more memory depending on the amount of data being indexed (JAVA OOM errors). In that case, the only option is to bump the system memory and increase the JAVA heap limit.
       Update Java heap limit for SOLR To 8GB:
     In the registry under, "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\solrservice\"
     Look for the APP Parameters and add -m 2G,
     Restart the service.
 
  • Start the Solr service from the FileCloud Control Panel

Notes:

https://www.filecloud.com/supportdocs/fcdoc/latest/server/filecloud-administrator-guide/filecloud-site-setup/document-settings/setting-up-content-search-for-documents/solr-config-tips