PDF preview in the Web UI returns and error
Original Question or Issue:
When previewing a PDF file from the Web UI, an error message is returned, CLFC-02005-02006 Preview watermark failed.
Environment:
- Product - Any
- Version - Any
- Platform - Any
Steps to Reproduce:
Error or Log Message:
An error occurred while loading the PDF
The server logs would show the following error lines
2024-08-12 11:12:29.356160 DEBUG: [17234791475969] Docconvert: Adding watermark to PDF with FC document converter
2024-08-12 11:12:31.524388 ERROR: [17234791475969] CLFC-02005-02006 Preview watermark failed. Contact site administrator(Failed to connect to 127.0.0.1 port 8080 after 2000 ms: Connection refused).
Defect or Enhancement Number:
Cause:
This could happen if the DocConverter service is not running.
Resolution or Workaround:
Make sure that the DocConverter service is running. It can be started from the FileCloud Control Panel or Windows Services. If running Linux (RHEL or Ubuntu) use the systemctl status <servicename> or service <servicename> status commands
Notes: