MongoDB service refuse to start
Original Question or Issue:
MongoDB service cannot be started from FileCloud Control Panel.
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Windows
Steps to Reproduce:
MongoDB service refuse to start from FileCloud Control Panel.
Error or Log Message:
Service failed to start within a reasonable time: MongoDB.
Defect or Enhancement Number:
Cause:
MongoDB data corruption seen in MongoDB logs c:\xampp\mongodb\bin\logs\
{"t":{"$date":"2024-09-27T09:39:52.232+02:00"},"s":"F", "c":"STORAGE", "id":50882, "ctx":"initandlisten","msg":"Failed to open WiredTiger cursor. This may be due to data corruption","attr":{"uri":"table:index-3-1354693429180315330","config":"overwrite=false","error":{"code":8,"codeName":"UnknownError","errmsg":"-31802: WT_ERROR: non-specific WiredTiger error"},"message":"Please read the documentation for starting MongoDB with --repair here: http://dochub.mongodb.org/core/repair"}}
Resolution or Workaround:
Please note you'll need to restore MongoDB data from last available autobackup:
- Move or remove content of MongoDB data path c:\xampp\mongodb\bin\data\*
- Start MongoDB service from FileCloud Control Panel.
- unzip last available FileCloud auto_db_dump.
- Open windows cmd as administrator and run DB restore command like below:
c:\xampp\mongodb\bin\mongorestore.exe --noIndexRestore --gzip --drop [path to unzipped db dump]
Notes: