MongoDB service has stopped immediately
Original Question or Issue:
One of the nodes of the database replica set had the mongo service as stopped this morning. I restarted it, but the node seems to be stuck in “RECOVERING”
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
Error or Log Message:
{"t":{"$date":"2025-03-04T02:26:42.968-07:00"},"s":"E", "c":"WT", "id":22435, "ctx":"thread15","msg":"WiredTiger error message","attr":{"error":28,"message":{"ts_sec":17408212023,"ts_usec":9678632,"thread":"2056:1407223721037920","session_name":"log-server","category":"WT_VERB_DEFAULT","category_id":9,"verbose_level":"ERROR","verbose_level_id":-3,"msg":"int __cdecl __log_prealloc_once(struct __wt_session_impl *):514:log pre-alloc server error","error_str":"No space left on device","error_code":28}}}
Defect or Enhancement Number:
Cause:
There is not enough space on the disk. Since MongoDB could not allocate the required space, it resulted in an immediate exit due to an unhandled exception:
Resolution or Workaround:
Check and Free disk space
Notes: