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Forcepoint alert email

Original Question or Issue:

Since integrating FileCloud with Forcepoint CDR, the admin has been receiving alert emails.


Environment:

  • Product - FileCloud Server
  • Version - 23,241
  • Platform - Any

Steps to Reproduce:

Integrate FileCloud with Forcepoint CDR.

Permission/lock issue when uploading to a network share.


Error or Log Message:

Due to an application error, a recently uploaded file by username is currently unavailable for use: /SHARED/username/file.txt
This file will remain in quarantine until the error is resolved or the request is canceled by an administrator.

Defect or Enhancement Number:

 


Cause:

Failed to upload some files to a network share after Forcepoint CDR successfully sanitized them.


Resolution or Workaround:

  • Verify FileCloud server logs for the same day of receiving the email:
    _______________________
    Linux: /var/www/html/scratch/logs/log_YYYY-MM-DD.txt
    Windows: <Drive Letter>:\xampp\htdocs\scratch\logs\log_YYYY-MM-DD.txt
    _______________________
         
  • The errors below are seen and the file is put into quarantine:
    _______________________
    CLFC-01404 FileUpload: Delete /SHARED/username/file.txt failed.
    addFile: Upload failed. Unable to move current live path - /SHARED/username/file.txt
    _______________________
        
  • The CRON job will retry every 5 minutes until the file is uploaded or an Admin deletes the file from quarantine:
    _______________________
    Retrying failed CDR record number 1, path /SHARED/username/file.txt, created at 2025-04-04 01:56
    Added the sanitized file in the Storage.

Notes: