Domain Change in Multitenancy
Original Question or Issue:
We want to change the domain in the FileCloud URL to match our new company domain.
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
Multi-Tenancy Support enabled.
Error or Log Message:
Defect or Enhancement Number:
Cause:
The company domain was changed.
Resolution or Workaround:
- Update the DNS records of all the tenants.
- Based on SSL termination, the SSL certificate should be updated in the Load Balancer and/or the FileCloud web nodes.
- Update the tenant site URL in the FileCloud superadmin portal.
- Based on SSL termination, add https to Tenant Admin Portal > Settings > Server > Server URL.
- If you're using SSO, FileCloud URLs in the IDP must be changed and IDP metadata re-imported in FileCloud.
- Verify the Host field in your FileCloud licenses and check whether the new domain is included. Otherwise contact FileCloud Support.
- If present, add the new domain to the below flag in cloudconfig.php:
define("TONIDOCLOUD_ALLOWED_HOSTS", "mydomain.com")
Notes: