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XML error when downloading file from S3 storage type.

Original Question or Issue:

File download fails and the web browser displays an XML error (Request has expired). 


Environment:

  • Product - FileCloud Server
  • Version - 
  • Platform - Windows, Linux

Steps to Reproduce:

 


Error or Log Message:

The browser displays something like below. 

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Code>AccessDenied</Code>
<Message>Request has expired.</Message>
<RequestId>695B99A8831467845</RequestId>
<HostId>file-cloud-storage_S3_bucket_location</HostId>
<Expires>20260105T105944Z</Expires>
<ServerTime>20260105T105952Z</ServerTime>
<X-Amz-Expires>120</X-Amz-Expires>
</Error>


Defect or Enhancement Number: 


Cause:

This issue happens when there is a time skew between the FileCloud server and the S3 storage server.


Resolution or Workaround:

Ensure that the FileCloud server and S3 storage server times are correct. 


Notes: