Workflow doesn't work after user was deleted
Original Question or Issue:
How to assign a workflow to another user?
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
Delete a user who created a workflow that is used in a policy.
Error or Log Message:
The workflow has no effect anymore after user was deleted.
Defect or Enhancement Number:
Cause:
The owner of the workflow doesn't exist anymore in the system.
Resolution or Workaround:
Assign the workflow to another existing user:
- Backup FileCloud server and MongoDB databases.
- Run below commands from MongoDB shell:
_________________________use tonidoclouddb;
db.automation_workflow.find();
_________________________
- Locate the workflow you want to assign to another user.
- Use the below DB command to modify the workflow owner:
______________________________________db.automation_workflow.updateOne({_id: ObjectId('6780fcc61e4dec73d1049080')},{$set:{createdby: 'meriem'}});
______________________________________
Notes:
Change the ObjectId and the createdby user according to you environment.