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Web DRM not working and shows an Inactive status

Original Question or Issue:

Why is WebDRM not working in my FileCloud system? The Web DRM check in the Admin Portals shows a status of Inactive. 


Environment:

  • Product - FileCloud Server, FileCloud Online
  • Version - Any
  • Platform - Windows

Steps to Reproduce:

This can be reproduce if FileCloud is installed in a different dirve other than the default C drive.


Error or Log Message:

The webdrm-wss logs are showing the lines below:

{"level":"error","message":"[WebSocketServer] Failed to report health. Error: spawn C:\\xampp\\php\\php.exe ENOENT","service":"webdrm-wss","timestamp":"2026-02-10T02:57:33.290Z"}


Defect or Enhancement Number:

FCL-7687


Cause:

The \xampp\webdrm\index.js file statically points to the PHP installation in drive C. When the XAMPP directory is installed in a different path, this breaks the webdrm functionality.


Resolution or Workaround:

Update the \xampp\webdrm\index.js file to point to the correct PHP directory.

  1. Connect to the FileCloud Server.
  2. Navigate to the <drive>:\xampp\webdrm\ path.
  3. Locate the index.js file and open using a text editor. 
  4. Manually locate the string C:\x5cxampp\x5cphp\x5cphp.exe and modify the drive letter accordingly to match the current XAMPP directory.
  5. Save the changes.

Notes: