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Users cannot login because they are not receiving 2FA codes in email.

Original Question or Issue:

Why are users not receiving emails with 2FA codes causing them to not be able to log in to FileCloud?


Environment:

  • Product - FileCloud Server, FileCloud ServerSync, FileCloud Sync, FileCloud Drive, FileCloud Desktop
  • Version - 23.253
  • Platform - Windows, Linux, MacOS

Steps to Reproduce:

 


Error or Log Message:

Server logs are showing the lines below:

1:SMTP ERROR: DATA END command failed: 550-From header sender domain not verified (<domain of the Email From Address>)

550-On your Sending > Verified Senders page

550 verify the sender domain or email to be allowed to send.


Defect or Enhancement Number:

 


Cause:

The emails containing 2FA codes are not getting sent out to users due to the following:
  • Email Settings in the Admin Portal still use the default SMTP settings, this is not recommended.
  • The Email From Address uses  a domain that is not verified by the domain of the SMTP Server in the Email Settings.

Resolution or Workaround:

FileCloud recommends the following solution:

  • User your own SMTP settings instead of using the default SMTP settings included in the FileCloud Admin Portal.
  • Make sure to use an Email From Address that has a verified domain by your SMTP Server.

Notes: