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SSO white space causes errors

Original Question or Issue:

When configuring SSO, if white spaces are at the end of the field, it errors out.


Environment:

  • Product - FileCloud Server
  • Version - Any
  • Platform - Any

Steps to Reproduce:

 


Error or Log Message:

https://sts.windows.net/XX/ “ for TONIDOCLOUD_SAML_IDP_URL

http://schemas.xmlsoap.org/ws/XX/XX/identity/claims/name “ for TONIDOCLOUD_SAML_USERNAME_PARAM. 


Defect or Enhancement Number:

FCL-6965


Cause:

Empty white space in the parameter for one or many of the SSO options.  In the error logs there is a trailing white space just before the last quotationutation mark.


Resolution or Workaround:

Ensure there is no white space if you enter your values.  If copy/pasting values, ensure no extra white space at the end.


Notes: