SSO SAML Blank Page error
Original Question or Issue:
- 'Log in with SSO' is redirecting to a blank page while trying to log into the FileCloud Server from the web interface
Environment:
- Product - FileCloud Server/Online
- Version - 23.252
- Platform - Linux
Steps to Reproduce:
- Configure SSO (SAML) from the Admin Portal
- Configure the IdP (Azure)
- Configure the SP (FileCloud)
- Try logging into the Web Portal using the 'Log in with SSO' button
Error or Log Message:
- After pressing 'Log in with SSO' button, a blank white screen appears
FileCloud Server Logs (SAML-related errors): - YYYY-MM-DD 11:47:10.353242 DEBUG: [1544578][17612380302815] SAML Authentication Failed SAML Authentication Failed
- YYYY-MM-DD 11:52:21.036465 DEBUG: [1545441][17612383410192] getSamlConfig: saml cert directory not found at /var/www/html/resources/samlcerts/default/
Defect or Enhancement Number:
Cause:
- The IdP (Azure) was looking for this specific parameter inside the FileCloud SSO settings:
http://schemas.xmlsoap.org/ws/2005/05/identity/claims/mail - After reviewing, the FileCloud Server SSO settings had been configured with this parameter:
http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress
Resolution or Workaround:
- After fixing the incorrect parameter '/emailaddress' to instead be '/mail' in the Admin Portal, SSO began working as expected
Notes:
- SAML SSO Support Documentation:
https://www.filecloud.com/supportdocs/fcdoc/latest/server/filecloud-administrator-guide/filecloud-site-setup/user-authentication-settings/single-sign-on-sso/saml-single-sign-on-support - Entra ID Integration Documentation:
https://www.filecloud.com/supportdocs/fcdoc/latest/server/filecloud-administrator-guide/filecloud-site-setup/user-authentication-settings/single-sign-on-sso/saml-single-sign-on-support/integrate-microsoft-entra-id-with-filecloud