SSO not working
Original Question or Issue:
The users can't sign in to my FileCloud Server with SAML.
Environment:
- Product - FileCloud Server
- Version - 23.242
- Platform - Any
Steps to Reproduce:
Upgrade FileCloud to release 23.251
Error or Log Message:
SSO doesn't show any redirection happening in the FileCloud server logs.
Defect or Enhancement Number:
Cause:
Using a custom port in the FileCloud server URL.
Resolution or Workaround:
Add the below flag in the cloudconfig.php file to force redirection:
define("TONIDOCLOUD_SSO_FULLURL_OVERRIDE", "https://FILECLOUD.URL:PORT");
Notes:
The cloudconfig file can be found under the path:
Linux: /var/www/html/config/cloudconfig.php
Windows: <Drive_Letter>:\xampp\htdocs\config\cloudconfig.php