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SSO Login returns blank page, with "License check failed" error

Original Question or Issue:

 


Environment:

  • Product - FileCloud Server, FileCloud Online
  • Version - Any
  • Platform - Windows, Linux, MacOS

Steps to Reproduce:

  1. Assign all available license seats to users.

  2. Configure SSO authentication in the Admin Portal 
  3. Log in with SSO from the Web User Portal.

  4. Check the server logs for this line below:
2026-04-17 9:39:44.678019 ERROR: [7020][17763657880333]  CodeLathe\Core\Subsystem\System\License\LicenseManager::isLicenseValid : License check failed: The number of active users exceeds the maximum of 20 license accounts.


Error or Log Message:

2026-04-17 9:39:44.678019 ERROR: [7020][17763657880333]  CodeLathe\Core\Subsystem\System\License\LicenseManager::isLicenseValid : License check failed: The number of active users exceeds the maximum of 20 license accounts.


Defect or Enhancement Number:

 


Cause:

All license seats have been used before configuring and utilizing SSO.


Resolution or Workaround:

  1. Check server logs for a similar error.
  2. Log in to the Admin Portal and confirm if you still have available license seats. This can be done from the Admin Portal Dashboard or from License tab under Settings
  3. Once confirmed that you no longer have an available license seat, contact our FileCloud Sales team to request for an update in your FileCloud license. 

Notes: