SSO Login returns blank page, with "License check failed" error
Original Question or Issue:
Environment:
- Product - FileCloud Server, FileCloud Online
- Version - Any
- Platform - Windows, Linux, MacOS
Steps to Reproduce:
-
Assign all available license seats to users.
- Configure SSO authentication in the Admin Portal
- Log in with SSO from the Web User Portal.
- Check the server logs for this line below:
Error or Log Message:
2026-04-17 9:39:44.678019 ERROR: [7020][17763657880333] CodeLathe\Core\Subsystem\System\License\LicenseManager::isLicenseValid : License check failed: The number of active users exceeds the maximum of 20 license accounts.
Defect or Enhancement Number:
Cause:
All license seats have been used before configuring and utilizing SSO.
Resolution or Workaround:
- Check server logs for a similar error.
- Log in to the Admin Portal and confirm if you still have available license seats. This can be done from the Admin Portal Dashboard or from License tab under Settings.
- Once confirmed that you no longer have an available license seat, contact our FileCloud Sales team to request for an update in your FileCloud license.
Notes: