Skip to content
English
  • There are no suggestions because the search field is empty.

SSO Log Out URL is not working

Original Question or Issue:

When setting SSO authentication and indicating a log out URL, users encounter and error page when logging out from the FileCloud Web UI.


Environment:

  • Product - FileCloud Server/Online
  • Version - Any
  • Platform - Any

Steps to Reproduce:

 


Error or Log Message:

Below is an example screenshot when using Azure Entra ID as IdP provider:

706a1bc30ba01d7dad1e19b74fe0ecc6fb2209f1472c30e6fc6c4d48d5ea63a2d8946aa202274591?t=1649d9094d094d352cce031b17bc7ce8


Defect or Enhancement Number:

 


Cause:

A flag in the FileCloud Server has not been enabled:

b92eff34b3beb6954da21d1fcf3c662605ec79d817e8f4a1f98a9e6a5a0de39edd4e09cb351c98f5?t=0d24f619a8d19235ebf026799dd92850


Resolution or Workaround:

 


Notes:

  • Make sure that the correct URL is indicated in the Admin Portal >> Settings >> SSO >> IdP Log Out URL (Optional) field. This value can be found in your SAML application.
  • Add a setting to the FileCloud config file:

    1. Open the configuration file:
      Windows: XAMPP DIRECTORY/htdocs/config/cloudconfig.php
      Linux: /var/www/config/cloudconfig.php
    2. To make the IdP Log Out URL setting effective, add:
      define("TONIDOCLOUD_SAML_SIGNED_LOGOUT", 1);

  • For FileCloud Online/GovCloud instances, contact FileCloud Support