SSO API Group Import and automatic account approval
Original Question or Issue:
When a new user is synced via SSO api integration how do they get activated?
Environment:
- Product - Any
- Version - 23.252 or above
- Platform - Any
Steps to Reproduce:
Error or Log Message:
Defect or Enhancement Number:
Cause:
When importing groups via the SSO API feature, new accounts are automatically disabled.
Resolution or Workaround:
There is a setting with Settings > settings > sso > Automatic account approval. Set this to the desired setting for automatic approval.
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No Automatic approval, Admin has to approve account
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Default. The account can be created by the user but the user cannot log in. The account requires admin approval for the user to access it.
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Automatically approve new accounts to Full User
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The user can create the account and immediately log in to FileCloud without waiting for admin approval. The account has Full User permission.
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Automatically approve new accounts to Guest User
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The user can create the account and immediately log in to FileCloud without waiting for admin approval. The account has Guest User permission. Later the admin can change the permission to Full User permission.
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Automatically approve new accounts to External User
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The user can create the account and immediately log in to FileCloud without waiting for admin approval. The account has External User permissio
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Notes: