Server URL won't update to https:// with self-signed certificate
Original Question or Issue:
I'm unable to update my FileCloud Server's URL to reflect "https://" after installing a self-signed SSL Certificate
Environment:
- Product - FileCloud Server
- Version - 23.252
- Platform - Windows
Steps to Reproduce:
- Install FileCloud Server
- Create a self-signed certificate, and upload the .crt and .key files through the FileCloud Control Panel
- Navigate to the Admin Portal > Settings > Server > ... try to update the Server URL to contain 'https://<domain>'
- Press the 'Check URL' button
- Error message will occur in the Admin UI
Error or Log Message:
- Error: Server URL is invalid
- Browser itself will also show a 'Not Secure' warning due to the nature of it being a self-signed certificate (this is a browser-specific issue, and not FileCloud specific)
Defect or Enhancement Number:
Cause:
- A self-signed certificate will not be recognized as being from a certified authority and therefore will cause issues while trying to authenticate applications and other services on FileCloud
Resolution or Workaround:
- Retrieve an SSL Certificate from a trusted authority (Let's Encrypt, GoDaddy, etc..) after registering your domain
- After retrieving the SSL Certificate, use the FileCloud Control Panel > Install SSL Cert UI to then apply the .crt, .key, and (if applicable) the ca-chain successfully
- Navigate to C:\xampp\apache\conf\extra\httpd-ssl.conf and modify the section that reads ServerName:443 to your actual domain name (filecloud.exampledomain.com:443)
- Restart Apache
- Server URL should now be able to be modified normally to "https://" without displaying error messages
Notes:
HTTPS Best Practices support documentation:
https://docs.filecloud.com/fcdoc/latest/server/filecloud-administrator-guide/installing-filecloud-server/post-installation/ssl-configuration/https-best-practices-for-filecloud