SAML SSO certificate issue
Original Question or Issue:
SAML SSO login not working after August 3rd.
If you are operating on a FileCloud version of 23.242 or below, your SAML certificate expired on 3rd Aug 2025. This may lead to an outage issue where users are unable to log in to their FileCloud sites.
Environment:
- Product - FileCloud Server
- Version - 23.242 and below
- Platform - All
Steps to Reproduce:
The saml certificate bundled with FileCloud release 23.242 and below has expired.
Error or Log Message:
Blank page when logging in using SSO.
Defect or Enhancement Number:
Cause:
SAML Certificate expired on August 3rd, 2025. Customers running version 23.242 or below, using SimpleSaml SSO and do not have their own certificates installed within /thirdparty/simplesaml/config/config.php
Resolution or Workaround:
Replace it in all the FileCloud web nodes under the path:
- <Drive_Letter>:\xampp\htdocs\thirdparty\simplesaml\cert\saml.crt
- /var/www/html/thirdparty/simplesaml/cert/saml.crt
You can download the certificate from the link below:
Also updating your system to version 23.251 will update the certificate.
Any issues please open up a ticket with FileCloud Support.
Notes:
Your SSO IDP provider may require you to import and trust the new certificate.
This has been seen with ADFS integration; you must check the Relying Party Trusts and import the new certificate in the Signature and Encryption tabs.