Office Online On-prem web edit not working
Original Question or Issue:
Office Online Onprem web edit not working
Environment:
- Product - FileCloud Server/Online
- Version - Any
- Platform - Any
Steps to Reproduce:
Error or Log Message:
Can't establish a TLS or SSL connection error in the OOS server ULS logs located at C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS
Defect or Enhancement Number:
Cause:
Strong cryptography support is not enabled for .NET Framework 4.5 or higher in OOS server
Resolution or Workaround:
Make changes in OOS server as per the section "Enable strong cryptography in .NET Framework 4.5 or higher" and reboot the OOS server.
https://learn.microsoft.com/en-us/officeonlineserver/enable-tls-1-1-and-tls-1-2-support-in-office-online-server
Notes: