No Promoted Admin User can login to the Admin Portal
Original Question or Issue:
All promoted admin users are unable to login to the FileCloud Admin Portal
Environment:
- Product - FileCloud Server/Online
- Version - Any
- Platform - Any
Steps to Reproduce:
Disable all existing admin roles.
Error or Log Message:
Server logs are showing the lines below:
2025-03-24 18:45:23.608755 DEBUG: [17428599235597] START [192.168.137.1] POST filecloudlabs.com:/admin/adminlogin?time=1742859923
2025-03-24 18:45:23.609458 DEBUG: [17428599235597] Rewriting URI: /admin/adminlogin?time=1742859923 => /admin/adminlogin?time=1742859923&op=adminlogin
2025-03-24 18:45:23.656771 DEBUG: [17428599235597] Critical Section: Acquired ADMINLOGIN_johnsmith 67e1ee938bf445.047660131742859923.559767e1ee938bf4b6.46902947
2025-03-24 18:45:23.669052 ERROR: [17428599235597] adminlogin error: No access to Admin system. Error code: CLFC-00153
2025-03-24 18:45:23.671448 DEBUG: [17428599235597] Critical Section: Released ADMINLOGIN_johnsmith who 67e1ee938bf445.047660131742859923.559767e1ee938bf4b6.46902947
2025-03-24 18:45:23.674122 DEBUG: [17428599235597] log : LOGGING AUDIT adminlogin
Defect or Enhancement Number:
Cause:
No admin role was enabled.
Resolution or Workaround:
- Log in using the master admin account.
- If you have no access to the master admin account and are a FileCloud Online customer, please contact FileCloud Support.
- If you have a FileCloud Server instance, and you do not have or forgot the master admin password, you may use the following methods to reset the admin password.
- Once you can access the Admin Portal, ensure an admin role exists and is enabled in the Admin screen.
- If an admin role exist but no user have been promoted, you have an option to promote a user to admin by clicking on the edit button beside the role.
- Click on the Users tab.
- Click on Add Users to Role and search for the user that you want to promote.
- Click on Close.
Notes: