Network Shares in Linux doesn't show files intermittently
Original Question or Issue:
Network Share doesn't show files intermittently
Environment:
- Product - FileCloud Server
- Version -
- Platform - Linux
Steps to Reproduce:
Error or Log Message:
cifs.upcall[791288]: check_service_ticket_exists: unable to get client principal from cache: No credentials cache found (filename: /tmp/krb5cc_0)
cifs.upcall[791288]: main: valid TGT is not present in credential cache
cifs.upcall[791288]: Exit status 1
kernel: CIFS: VFS: Verify user has a krb5 ticket and keyutils is installed
Defect or Enhancement Number:
Cause:
In Linux environments, using Kerberos authentication to mount Network Shares can cause issues with Apache from accessing the Kerberos cache.
Resolution or Workaround:
Remove the sec=krb5 reference from CIFS mount parameters in /etc/fstab
If the current config is as follows:
//fs01/share /mount/path cifs credentials=/root/.smbcredentials,uid=33,gid=33,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777,sec=krb5,noserverino 0 0
Change it to:
//fs01/share /mount/path cifs credentials=/root/.smbcredentials,uid=33,gid=33,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777,noserverino 0 0
Remount the shares and restart Apache after this change.
Alternatively, customer can configure Kerberos authentication with KeyFab, etc., to make sure Apache can access the shares without any issues.
Notes: