Network Share creation failed due to lack of permissions
Original Question or Issue:
Network Share creation failed with the error message "Invalid path specified. The path does not exist."
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
From the Admin Portal > navigate to Network share > Add > Select network type > Name > Mount type > Mount path
Error or Log Message:
Invalid path specified. The path does not exist
Defect or Enhancement Number:
Cause:
Due to the lack of permissions
Resolution or Workaround:
Selecting which permissions will be effective for the Network share is essential.
We must ensure that the service account has sufficient access to the Network share path.
- Step 1 – Locate the document in the drive for which you want to view the permissions.
- Step 2 – Right-click the folder or file and click “Properties” in the context menu.
- Step 3 – Switch to the “Security” tab and click “Advanced”.
- Step 4 – In the “Permissions” tab, you can see the permissions held by users over a particular file or folder.
- Step 5 – Click “Effective Access” tab.
- Step 6 – Click “Select a user” to add the user or group whose effective permissions you want to view. A list of all the effective permissions the user holds will be displayed on the bottom panel of the “Advanced Security Settings” window.
Kindly ensure that the account running the FileCloud services has sufficient access to the folder path.
Notes: