MongoDB Alert in Admin Portal
Original Question or Issue:
There are critical MongoDB errors in the FileCloud Admin Portal > Alert tab.
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
Dedicated FileCloud MongoDB nodes in replica set mode.
Error or Log Message:
Not primary so we cannot begin or continue a transaction.
Defect or Enhancement Number:
Cause:
Network disconnection between the FileCloud App/Web and the MongoDB nodes.
Resolution or Workaround:
Fix the network ACL for the MongoDB IPs and default port 27017.
Notes: