Skip to content
English
  • There are no suggestions because the search field is empty.

Missing files in managed storage

Original Question or Issue:

I'm unable to download some files from the FileCloud User Interface after performing a storage migration.


Environment:

  • Product - FileCloud Server
  • Version - Any
  • Platform - Any

Steps to Reproduce:

Storage migration.


Error or Log Message:

FileCloud server logs display "Missing file in storage DB" when attempting to download a file.


Defect or Enhancement Number:

 


Cause:

Missed user files during the storage migration.


Resolution or Workaround:

- Connect to the FileCloud server via RDP and open a Windows CMD.

- Run the storage scanner tool to identify the missing files:

cd <Drive_Letter>:\xampp\htdocs\resources\tools\fileutils
<Drive_Letter>:\xampp\php\php.exe storagescanner.php  


Notes:

A detailed usage of the command can be seen in: Storage scanner tool for missing files