Skip to content
English
  • There are no suggestions because the search field is empty.

Large File Uploads Fail at 100% with Network Error Due to S3 CORS Configuration

Original Question or Issue:

Customer reported an issue when uploading files through a guest account. A CORS policy error was previously observed during the upload process.


Environment:

  • Product - FileCloud Server
  • Version - 23.262
  • Platform - Linux

Steps to Reproduce:

  • Access FileCloud using the guest account.
  • Attempt to upload a large file.
  • Monitor the browser Developer Tools Console and Network tabs for errors.
  • Re-upload the same file if necessary.

Error or Log Message:

Previously reported: CORS policy error in the browser Developer Tools.

During the latest support test, the CORS error could no longer be reproduced.


Defect or Enhancement Number:

No JIRA assigned


Cause:

The issue appears to be related to CORS configuration on the S3 bucket. During troubleshooting, CORS errors were observed in the browser console when the FileCloud client attempted to access the S3 bucket during large file uploads.


Resolution or Workaround:

 The Online Operations team added the CORS policy to the customer's S3 bucket and .htaccess file. 

Configure System to Use Optimized Upload 


Notes: