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Invalid Email for External Accounts error

Original Question or Issue:

While creating an External User account, an error message displayed that said: "Invalid Email for External Accounts"


Environment:

  • Product - FileCloud Server/Online
  • Version - 22.1 >
  • Platform - Any

Steps to Reproduce:

  • From the Admin Portal > Users/Groups Users > Add User
  • Set that new user's 'Access Level' to 'External'
  • Set that user's email domain to match the domain of at least 10% of other FileCloud users

Error or Log Message:

"Invalid Email for External Accounts"


Defect or Enhancement Number:

 


Cause:

  • Domain limitations for External Users are effective for FileCloud beginning in version 22.1
  • If external users have the same domains that at least 10% of licensed users have before the rule was put into effect, the external users are allowed to remain with their current emails.


Resolution or Workaround:

  • Use an alternate domain name while creating an External User account if you receive this error message.  This will allow External User account creation as expected.

Notes:

See the Support Documentation linked below:

https://www.filecloud.com/supportdocs/fcdoc/latest/server/filecloud-administrator-guide/filecloud-site-setup/user-settings/new-account-creation/domain-limitations-for-external-users