Some users are seeing HTTP error while accessing the website even though SSL certificate is installed
Original Question or Issue:
External users are seeing an HTTP connection while accessing the domain even though there is an SSL certificate installed on it
Environment:
- Product - FileCloud Server
- Version - any
- Platform - any
Steps to Reproduce:
While accessing the website in the browser it will show an HTTP connection instead of HTTPS
Error or Log Message:
Defect or Enhancement Number:
Cause:
The SSL certificate is not correctly installed with all three required components: the SSL certificate, the private key, and the intermediate (chain) certificates.
Resolution or Workaround:
Make sure the name resolves to the correct server and that the SSL port (default: 443) is open on the server's firewall. Try reinstalling the SSL certificate, the Private key, and the chain certificate.
By default, FileCloud uses these 3 ports:
-
80 (web server)
-
443 (web server)
-
27017 (database)
Notes:
https://docs.filecloud.com/fcdoc/latest/server/filecloud-administrator-guide/installing-filecloud-server/post-installation/ssl-configuration/use-ssl-on-windows/install-a-certificate-using-the-filecloud-control-panel
https://docs.filecloud.com/fcdoc/latest/server/filecloud-administrator-guide/installing-filecloud-server/post-installation/ssl-configuration/use-ssl-on-linux/install-an-ssl-certificate-on-linux