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FileCloud ICAP Antivirus Rejected Due to REQMOD/RESPMOD Configuration

Original Question or Issue:

ICAP antivirus requests are being rejected because FileCloud is sending REQMOD requests while ICAP protection task is configured for RESPMOD only.  Can this be changed?


Environment:

  • Product - FileCloud Server/Online
  • Version - Any
  • Platform -Any

Steps to Reproduce:

  • Upload a file to FileCloud

  • FileCloud sends ICAP request to port 1344

  • ICAP service rejects the request due to REQMOD vs RESPMOD mismatch


Error or Log Message:

 


Defect or Enhancement Number:

 


Cause:

FileCloud ICAP antivirus scanning operates at file upload time and sends REQMOD requests by design. The ICAP service was configured to accept RESPMOD requests only.


Resolution or Workaround:

FileCloud cannot switch ICAP scanning to RESPMOD. The ICAP protection task on the Kaspersky side must be configured to accept REQMOD requests for scanning to function correctly.


Notes:

For further information regarding ICAP AV, please see the following support documentation linked below:

https://docs.filecloud.com/fcdoc/latest/server/filecloud-administrator-guide/third-party-integrations-settings/enable-antivirus-scanning/use-icap-antivirus-scanning