Skip to content
English
  • There are no suggestions because the search field is empty.

FileCloud Drive: Thumbs.db files are getting uploaded to the server.

Original Question or Issue:

When using FileCloud Drive, a file called Thumbs.db gets created, gets uploaded to the server, and could trigger a notification if you have workflow created to monitor new files.


Environment:

  • Product - FileCloud Server, FileCloud Drive, FileCloud Desktop
  • Version - Any
  • Platform - Windows, Linux, MacOS

Steps to Reproduce:

  1. Install FileCloud Drive and leave all default configurations.
  2. Open FileCloud Drive Explorer and navigate to a folder. Noticed that there is a file that gets created called Thumbs.db.
  3. The file gets uploaded to the server.

Error or Log Message:

 


Defect or Enhancement Number:

 


Cause:

This is a FileCloud Drive configuration.


Resolution or Workaround:

FileCloud Drive's config.xml file can be configured to prevent the Thumbs.db file from being uploaded. Follow the steps below:

 

  1. Completely close FileCloud Drive.
  2. Navigate to C:\Program Files\FileCloud Drive\service\.
  3. Locate the config.xml file and edit it using a text editor.
  4. Set the value of the parameter below, or add the line if it does not yet exist. To disable: <allowthumbsdbupload>0</allowthumbsdbupload> To enable: <allowthumbsdbupload>1</allowthumbsdbupload>
  5. Save the changes made to the file.
  6. Re-open FileCloud Drive, and the changes should take effect.

Notes: