DataBase Keeps Crashing Due to Security Software
Original Question or Issue:
The database service keeps crashing.
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
Error or Log Message:
{"t":{"$date":"XX"},"s":"F", "c":"CONTROL", "id":4757800, "ctx":"ftdc","msg":"Writing fatal message","attr":{"message":"DBException::toString(): FileRenameFailed: Access is denied\nActual exception type: class mongo::error_details::ExceptionForImpl<37,class mongo::AssertionException>\n"}}
Defect or Enhancement Number:
Cause:
Anti-virus or security software was stopping the Database.
Resolution or Workaround:
Whitelist the /xampp folder for the Anti-virus or security software.
Notes: