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Can't import some AD members

Original Question or Issue:

We added users to a specific AD group and clicked “import users from AD group” but no new account was created in FileCloud.


Environment:

  • Product - FileCloud Server
  • Version - Any
  • Platform - Any

Steps to Reproduce:

Import an AD group in FileCloud.


Error or Log Message:

appendADUserImportError: <b></b> - user must have a valid username:


Defect or Enhancement Number:

 


Cause:

Some AD members are misconfigured.


Resolution or Workaround:

Ask the AD administrator to compare the output of the command below for a working user with a non working one:

Get-ADUser -Identity "UserPrincipalName" -Properties *


Notes:

Replace UserPrincipalName in the above command.