Cannot login to admin portal
Original Question or Issue:
Cannot log in to the Admin Portal to a new license. Original FileCloud admin is no longer with the company.
Environment:
- Product - FileCloud Server
- Version - Any
- Platform - Any
Steps to Reproduce:
Error or Log Message:
Defect or Enhancement Number:
Cause:
The admin user name was changed to something they don't know thus the conventional admin password reset is not working.
Resolution or Workaround:
If access to the admin portal is not possible and the default admin username and password cannot be recovered, we can use the MongoDB Shell to retrieve what value was set for the admin username.
- Connect to the FileCloud Server host.
- Launch the MongoDB Shell from C:\xampp\mongodb\bin for Windows, and for the executable can be invoked directly.
- Mongo.exe for older versions
- Mongosh.exe for newer version of MongoDB
- Run the commands below
use tonidosettings
db.sites.find({ "settings.name": "TONIDOCLOUD_ADMIN_USER" }, { "settings.$": 1 }).pretty()
The command above should return something like:
[
{
_id: ObjectId("64b03e74f305487056027512"),
settings: [ { name: 'TONIDOCLOUD_ADMIN_USER', value: 'admin' } ]
}
]
Notes: