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Bypass the email attribute for an AD user

Original Question or Issue:

Our end users are not able to login to FileCloud after changing their email ID in AD, but we kept the original email address as an alternate email ID.


Environment:

  • Product - FileCloud Server
  • Version - Any
  • Platform - Any

Steps to Reproduce:

Add a new email ID in the AD account profile.

Keep the original email ID as an alternate email address.


Error or Log Message:

User email in FileCloud does not match the AD user email attribute.


Defect or Enhancement Number:

 


Cause:

FileCloud verifies the email attribute for an AD user during login.


Resolution or Workaround:

Bypass the email attribute check by adding the flag:

define("TONIDOCLOUD_BYPASS_AD_EMAIL_VERIFICATION_ON_AUTH", true);

To the FileCloud configuration file below:

Windows: <Drive_Letter>:\xampp\htdocs\config\cloudconfig.php

Linux: /var/www/html/config/cloudconfig.php


Notes:

If you activate the flag above, FileCloud will only verify the username and password during the login of an AD user.