Blank Folders intermittently using FileCloud Drive
Original Question or Issue:
- Users are intermittently seeing blank folders while viewing Team Folders via FileCloud Drive. When the user refreshes the folder, the content is then displayed normally.
Environment:
- Product - FileCloud Drive
- Version - 23.232.2.8781
- Platform - Windows
Steps to Reproduce:
- Open up FileCloud Drive, and navigate to a Team Folder and sub-folders within to view data
Error or Log Message:
- (on Windows) "Location is not available" :
"X:\Team Folders\sub-folder1\filename.txt\ is unavailable. If the location is on this PC, make sure the device or drive is connected or the disc is inserted, and then try again. If the location is on a network, make sure you're connected to the network or Internet, and then try again. If the location still can't be found, it might have been moved or deleted." - (FileCloud Server Logs) SOLR HTTP 400 Error:
Line 1526284: YYYY-MM-DD 11:37:33.604125 DEBUG: [56909][17596705137699] Solr Error occurred while indexing file [.../sub-folder2/FileName.txt] -- Solr HTTP error: Bad Request (400)
Defect or Enhancement Number:
Cause:
- HTTP 400 Errors from SOLR Service on the intermittently unavailable folder locations
- Managed Storage Index wasn't fully synchronized and had a large delta
Resolution or Workaround:
- Fully synchronize Managed Storage Index
- For hosted/online sites (Handled by our OnlineOps team)
- For On-Prem Servers:
- Admin Portal > Settings > Content Search
- Under the 'Managed Storage Index Status' select 'Sync'
- Log-out and then log back into the FileCloud Drive client application
Notes:
Content Search Support Documentation:
https://www.filecloud.com/supportdocs/fcdoc/latest/server/filecloud-administrator-guide/filecloud-site-setup/document-settings/setting-up-content-search-for-documents/configure-content-search-for-managed-storage
FileCloud Drive Support Documentation:
https://www.filecloud.com/supportdocs/fcdoc/latest/server/filecloud-client-applications-and-add-ins/filecloud-drive