Backup Server using Local DB
Original Question or Issue:
When conducting test of Filecloud backup feature it gives us an error during the backup process.
Environment:
- Product - FileCloud Server
- Version - 23,262.1
- Platform - Windows
Steps to Reproduce:
- HA Environment.
- Have multiple Web Nodes and DB nodes.
- Implement the backup server.
- Add the details for BACKUPAGENT_MONGODUMP_PARAMS in the backupagentconfig.php on the Backup Server.
Error or Log Message:
[ERROR]DB dump not found. Retry again.
[ERROR]onRestoreDB:Unable to find database export directory:
Defect or Enhancement Number:
Cause:
During the backup process, when connecting to the DB, even with authentication enabled, the request is hitting localhost instead of the correct DB location.
Resolution or Workaround:
Add a define on the Web Node to include TONIDOCLOUD_BACKUP_DBSERVER.
This should be formatted similarly to the TONIDOCLOUD_DBSERVER define.
Notes: